FANDOM


Author: flopperr999

Congratulations! You’re now set up to start actually building the map itself! However, first you must learn what tools you’ll be using, and what each tool is used for….

To see the tools and their locations, go to File>New

To construct the map’s architecture and texture it, you only need to use 4 of Zoner’s 11 Half Life tools. (Defaulted on the left after opening a new map via File>New.)

Zoner’s Half Life Tools will now be abbreviated by ZHLT for the rest of this tutorial.

The tools are:

Selection Tool: (1st Tool from the top the ZHLT) This the most widely used tool. This is used to resize blocks, and select blocks and faces (sides of a block).

Block Tool: (5th tool from the top of ZHLT) The block tool creates the building blocks of your map. The allowed use of blocks per map is unlimited, so go crazy with this tool! After you make a block in one of the three views (top, front, and side), you must hit enter/return for the block to actually be created. A created block is indicated by a change from the color white to another color.

Toggle Texture Application Tool: (6th tool from the top of ZHLT) This is the more advanced texture applicator of the two texture applicators. This tool not only allows you to apply a texture to a block, but also to set the scale of each texture, shift it’s placement, or rotate it.

Apply Texture Tool: (7th tool from the top of ZHLT) The simpler of the two texture applicator tools. With this tool, you can simply select a face of your box in the Camera view, browse for a texture you want to apply to the selected face, Click OK, and then select the Apply Texture Tool.


Also, in the Architechual Industry, the Front, Top, and Side views together are known as a Multiview drawing.

Now let’s get to it!

To see the textures in the camera view, go to View> 3D textured Polygons

Because you already hit File>New before, there’s a map already open, so there’s no need to open another. Select the block tool. Draw a square in one of the three views. It should appear as a square in all three of the views. However, it is actually cube. The default texture is some kind of pink and black circle with an upside down V inside it. This is okay, but I suggest changing that to what’s known as the NULL texture. That is the fourth to last one on the list for when you browse for textures. Just doblue-click that and it will be your default texture.

Because this is your first map, I suggest only using 3 or so distinguishable textures. (Bricks, wood, and metal. Etc..)

In my experience, I find that texturing things last is the easiest way to build a map, because you that way you can see the map’s geometry, you can then see what textures suit it best. But you can do as you please. After the box is created, select the box in the Camera view (You may have to wiggle around a bit to find it). Once selected, it should turn a shade of red (but if it’s textured with the null texture, it’ll turn black.) Once selected, go to Tools>Make Hollow. This will hollow out the inside of the box, that way, things can be built on the inside of it. I suggest making the walls 16 or 32 units thick. Never make a wall less than 8 units thick.

Once hollowed, you can start building what ever you want inside! For now, though, we’ll keep it empty. With the box still selected, go to Tools>Ungroup. From now on, when you select this block, you can only select one face at a time. This can be useful in texturing, moving walls, and plenty of other things.

SAVE YOUR WORK.

Now we can start with the second room of your map.

Make another block, about the same size as the other one. (Don’t make it exactly the same. Then you won’t be able to tell them apart!) Hollow that one out as well, and then texture it with whatever you want.

SAVE YOUR WORK

Now you’ve got two rooms, but how would Bond get from one to another?

A doorway, of course!

To make doorways, or holes in blocks, for that matter, you must use a block as your “Carver”. Create a block with the block tool wherever you want the doorway. It doesn’t matter if the block sticks out a little bit. After the block is created in the shape you want your doorway, go to Tools>Carve. Once you do that, delete the created block. The actual door will be added after you import the map into the Goldeneye Setup Editor. Now that’s a fine looking doorway if I do say so myself!

Windows can be created the same way. Just create an elevated block in a wall, and then carve it out, and then delete the block. Piece of cake =]

Lastly, with all maps, you must create a box textured with the NULL texture (4th to last texture in the texture list) surrounding your ENTIRE map, to prevent any “leaks” you may have in your map. Think of your map as a container of oxygen in the middle of space. If there’s a leak, all the air leaks out, you’re fate is…you….well….you’re rescued! ;)

Just create a block with the null texture around the map, and then hollow it out with the hollow option in Tools>Hollow.

Now you can add a start point!

Information on doing that will be included in the next tutorial. (Compiling and Importing)


Flopperr999

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.